Non-english languages in Peoplesoft Production are not working for OKTA users
Incident Report for CARE
Update
We are still investigating the minor issue encountered with regards to the languages in Peoplesoft Production for OKTA users.

For urgent concerns you may contact sscsuport@care.org if you need to change your language in Peoplesoft Production.
Posted Feb 20, 2022 - 16:21 GMT+08:00
Investigating
Please be informed that PeopleSoft Security Platform maintenance has been completed.

We discovered an minor issue during the validation process. Non-english languages are not working for OKTA users.
The system will redirect them to English language for now while we are working with the Security Platform vendor for the solution.

Apologies for the inconvenience.
Posted Feb 20, 2022 - 11:50 GMT+08:00
This incident affects: Finance and Grants Management System (PeopleSoft) (PeopleSoft Production environment).